Fee Estimations Unavailable

Incident Report for Utila

Resolved

The issue is resolved.
Posted Oct 25, 2025 - 12:59 UTC

Monitoring

A fix was implemented, we're monitoring.
Posted Oct 25, 2025 - 00:53 UTC

Identified

We are currently experiencing an issue that is preventing us from providing gas fee estimations for blockchain transactions. This impacts users attempting to estimate transaction costs prior to submission.
Posted Oct 25, 2025 - 00:39 UTC
This incident affected: RPC Provider.