Sui Network - Degraded Performance

Incident Report for Utila

Update

The Sui Mainnet is now online and actively processing blocks.
You can track live updates here:
https://status.sui.io/
Posted May 29, 2026 - 15:59 UTC

Update

We are actively monitoring an ongoing issue with the Sui Mainnet, which is currently experiencing a network-wide outage.
https://status.sui.io/
Posted May 29, 2026 - 14:43 UTC

Monitoring

The Sui Network is back online.
We are continuing to monitor the situation closely.
Network metrics: https://metrics.sui.io/public-dashboards/4ceb11cc210d4025b122294586961169
Status page: https://status.sui.io/
Posted May 28, 2026 - 21:28 UTC

Identified

Sui network Identified the issue and a fix is being implemented.
https://status.sui.io/
Posted May 28, 2026 - 15:40 UTC

Investigating

The Sui Network is currently experiencing an outage.
We are following the incident closely and monitoring for impact on Sui-related transactions and operations on the Utila platform.
https://status.sui.io/
Posted May 28, 2026 - 14:36 UTC
This incident affects: Blockchains (Sui).