Hedera Mainnet - Service Disruption

Incident Report for Utila

Resolved

This incident has been resolved.
Posted May 20, 2026 - 18:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
https://status.hedera.com/incidents/6558j95l840y
Posted May 20, 2026 - 18:52 UTC

Identified

The issue has been identified and a fix is being implemented.
https://status.hedera.com/incidents/6558j95l840y
Posted May 20, 2026 - 18:52 UTC

Investigating

We are aware that Hedera mainnet is undergoing scheduled maintenance (upgrade to v0.73.0), which is impacting Hedera-related operations on Utila platform.

Customers may experience the following on Hedera mainnet:
Outgoing transactions - submission may be delayed or fail
Incoming transactions - detection and confirmation are delayed
Balances - updates are delayed until the network resumes

Our team is monitoring the situation in coordination with Hedera's status updates.
All other networks on the Utila platform are unaffected.
We will provide further updates as more information becomes available.
Reference: https://status.hedera.com/incidents/6558j95l840y
Posted May 20, 2026 - 18:01 UTC
This incident affected: Blockchains (Hedera).