Degraded performance - Canton Mainnet

Incident Report for Utila

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 16:23 UTC

Investigating

We are currently investigating an issue with our Canton node provider, which is causing users to temporarily see zero balances and preventing to initiate transactions.
Posted Mar 19, 2026 - 16:07 UTC
This incident affected: Blockchains (Canton).