Inconsistencies With APTOS Transactions

Incident Report for Utila

Resolved

We are now compatible with the changes Aptos implemented, for USDC and USDT.
Thanks for your patience during this migration.
Posted Aug 05, 2025 - 10:57 UTC

Monitoring

We've updated Utila to ensure full compatibility with Aptos's recent network migration. All systems are operational and we continue monitoring to ensure optimal performance.
Posted Aug 03, 2025 - 18:10 UTC

Identified

We’ve identified the root cause of the Aptos issue: it stems from protocol changes on the Aptos side, as they migrate from a legacy format to a new protocol structure.

Our team is now working to adapt our systems to be fully compatible with the new format. We’ll continue to share updates as we make progress toward a full resolution.

Thanks for your continued patience.
Posted Aug 03, 2025 - 06:53 UTC

Update

We are continuing to investigate this issue.
Posted Jul 29, 2025 - 10:47 UTC

Investigating

We’re investigating possible inconsistencies affecting display of Aptos balances and transactions in Utila.
If you notice anything unusual, please reach out — it helps us pinpoint and resolve faster. We’ll share updates as we learn more.
Posted Jul 29, 2025 - 10:46 UTC
This incident affected: Blockchains (APTOS).