Delay In Ton Transactions

Incident Report for Utila

Resolved

The incident has been resolved.
Transaction processing is operating normally.
Posted Dec 15, 2025 - 18:30 UTC

Monitoring

We have implemented a fix and currently monitoring system performance to ensure transaction processing has returned to normal levels.
Next Update: Within 30 minutes
Posted Dec 15, 2025 - 17:55 UTC

Identified

The issue has been identified and our engineering team is implementing a resolution.
Next Update: Within 30 minutes
Posted Dec 15, 2025 - 17:32 UTC

Investigating

We are currently experiencing issues with TON transactions
Posted Dec 15, 2025 - 16:30 UTC
This incident affected: Blockchains (TON).